
<!DOCTYPE html>
<html lang="en-CA" prefix="og: https://ogp.me/ns#" class="no-js no-svg">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel='dns-prefetch' href='//ap.lijit.com/'>

<link rel='dns-prefetch' href='//aax.amazon-adsystem.com'>
<link rel='dns-prefetch' href='//c.amazon-adsystem.com'>
<link rel='dns-prefetch' href='//connect.facebook.net/'>
<link rel='dns-prefetch' href='//www.youtube.com'>
<link rel='dns-prefetch' href='//www.youtube-nocookie.com'>
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net'>

<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<title>SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals</title><link rel='preload' href='https://www.cgmagonline.com/wp-includes/js/jquery/jquery.min.js' as='script'><link rel='preload' href="https://fonts.googleapis.com/css?family=Roboto:400,100,100italic,300,300ita‌​lic,400italic,500,500italic,700,700italic" as='font'>
<meta name="description" content="Guardian, Destiny 2: The Witch Queen launches today and SteelSeries has you covered, with three acclaimed products in new branded variants."/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://www.cgmagonline.com/news/steelseries-gear-witch-queen-destiny-2/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals" />
<meta property="og:description" content="Guardian, Destiny 2: The Witch Queen launches today and SteelSeries has you covered, with three acclaimed products in new branded variants." />
<meta property="og:url" content="https://www.cgmagonline.com/news/steelseries-gear-witch-queen-destiny-2/" />
<meta property="og:site_name" content="CGMagazine" />
<meta property="article:publisher" content="https://www.facebook.com/ComicsGamingmagazine" />
<meta property="article:tag" content="Bungie" />
<meta property="article:tag" content="Steelseries" />
<meta property="article:section" content="News" />
<meta property="og:updated_time" content="2022-02-22T13:19:58-05:00" />
<meta property="fb:app_id" content="2402793370019467" />
<meta property="og:image" content="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/news-steelseries-gears-up-to-battle-the-witch-queen-with-limited-destiny-2-peripherals.jpg" />
<meta property="og:image:secure_url" content="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/news-steelseries-gears-up-to-battle-the-witch-queen-with-limited-destiny-2-peripherals.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta property="og:image:alt" content="SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-02-22EST09:00:00-05:00" />
<meta property="article:modified_time" content="2022-02-22EST13:19:58-05:00" />
<meta property="og:video" content="https://www.youtube.com/embed/PYM7KDrx_Ho" />
<meta property="video:duration" content="142" />
<meta property="ya:ovs:upload_date" content="2022-02-15" />
<meta property="ya:ovs:allow_embed" content="true" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals" />
<meta name="twitter:description" content="Guardian, Destiny 2: The Witch Queen launches today and SteelSeries has you covered, with three acclaimed products in new branded variants." />
<meta name="twitter:site" content="@cgmagonline" />
<meta name="twitter:creator" content="@cgmagonline" />
<meta name="twitter:image" content="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/news-steelseries-gears-up-to-battle-the-witch-queen-with-limited-destiny-2-peripherals.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Chris De Hoog" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="rank-math-schema-pro">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</script>

<link rel='dns-prefetch' href='//cdn.cgmagonline.com' />
<link rel='preconnect' href='//cdn.cgmagonline.com' />
<link rel="alternate" type="application/rss+xml" title="CGMagazine &raquo; Feed" href="https://www.cgmagonline.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CGMagazine &raquo; Comments Feed" href="https://www.cgmagonline.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CGMagazine &raquo; SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals Comments Feed" href="https://www.cgmagonline.com/news/steelseries-gear-witch-queen-destiny-2/feed/" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.cgmagonline.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.1' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://www.cgmagonline.com/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='main_stylesheet-css'  href='https://www.cgmagonline.com/wp-content/plugins/spotim-wordpress-plugin-master/assets/stylesheets/main.css?ver=5.9.1' media='all' />
<link rel='stylesheet' id='dalt-google-font-1-css'  href='https://www.cgmagonline.com/wp-content/cache/perfmatters/www.cgmagonline.com/fonts/dc1f160a9cca.google-fonts.css' media='all' />
<link rel='stylesheet' id='dalt-general-css'  href='https://www.cgmagonline.com/wp-content/plugins/league-table/public/assets/css/general-min.css?ver=2.13' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.cgmagonline.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.5.1' media='all' />
<link rel='stylesheet' id='bricks-frontend-css'  href='https://www.cgmagonline.com/wp-content/themes/bricks/assets/css/frontend-light.min.css?ver=1643288766' media='all' />
<style id='bricks-frontend-inline-css'>
#bricks-element-dzqedy {background-image: url(https://cdn.cgmagonline.com/wp-content/uploads/2022/02/news-steelseries-gears-up-to-battle-the-witch-queen-with-limited-destiny-2-peripherals.jpg?strip=all&#038;lossy=1&#038;ssl=1)}#bricks-element-dzqedy > .css-filter {background-image: url(https://cdn.cgmagonline.com/wp-content/uploads/2022/02/news-steelseries-gears-up-to-battle-the-witch-queen-with-limited-destiny-2-peripherals.jpg?strip=all&#038;lossy=1&#038;ssl=1)}
</style>
<link rel='stylesheet' id='bricks-color-palettes-css'  href='https://www.cgmagonline.com/wp-content/uploads/bricks/css/color-palettes.min.css?ver=1643908923' media='all' />
<link rel='stylesheet' id='bricks-global-custom-css-css'  href='https://www.cgmagonline.com/wp-content/uploads/bricks/css/global-custom-css.min.css?ver=1644513110' media='all' />
<link rel='stylesheet' id='bricks-theme-style-custom_cgmagazine-css'  href='https://www.cgmagonline.com/wp-content/uploads/bricks/css/theme-style-custom_cgmagazine.min.css?ver=1643908924' media='all' />
<link rel='stylesheet' id='bricks-post-301489-css'  href='https://www.cgmagonline.com/wp-content/uploads/bricks/css/post-301489.min.css?ver=1643908934' media='all' />
<link rel='stylesheet' id='bricks-post-314575-css'  href='https://www.cgmagonline.com/wp-content/uploads/bricks/css/post-314575.min.css?ver=1645472682' media='all' />
<link rel='stylesheet' id='bricks-post-301558-css'  href='https://www.cgmagonline.com/wp-content/uploads/bricks/css/post-301558.min.css?ver=1643908928' media='all' />
<link rel='stylesheet' id='bricks-font-awesome-css'  href='https://www.cgmagonline.com/wp-content/themes/bricks/assets/css/libs/font-awesome.min.css?ver=1643288766' media='all' />
<link rel='stylesheet' id='bricks-ionicons-css'  href='https://www.cgmagonline.com/wp-content/themes/bricks/assets/css/libs/ionicons.min.css?ver=1643288766' media='all' />
<link rel='stylesheet' id='bricks-google-font-0-css'  href='https://www.cgmagonline.com/wp-content/cache/perfmatters/www.cgmagonline.com/fonts/589b7f4c6e14.google-fonts.css' media='all' />
<link rel='stylesheet' id='bricks-google-font-1-css'  href='https://www.cgmagonline.com/wp-content/cache/perfmatters/www.cgmagonline.com/fonts/3adf6e9faf0b.google-fonts.css' media='all' />
<link rel='stylesheet' id='bricks-google-font-2-css'  href='https://www.cgmagonline.com/wp-content/cache/perfmatters/www.cgmagonline.com/fonts/57e8faab602c.google-fonts.css' media='all' />
<link rel='stylesheet' id='bricks-google-font-3-css'  href='https://www.cgmagonline.com/wp-content/cache/perfmatters/www.cgmagonline.com/fonts/465708235835.google-fonts.css' media='all' />
<link rel='stylesheet' id='bricks-google-font-4-css'  href='https://www.cgmagonline.com/wp-content/cache/perfmatters/www.cgmagonline.com/fonts/20cb36739ac3.google-fonts.css' media='all' />
<link rel='stylesheet' id='wp-featherlight-css'  href='https://www.cgmagonline.com/wp-content/plugins/wp-featherlight/css/wp-featherlight.min.css?ver=1.3.4' media='all' />
<script id='free-comments-for-wordpress-vuukle-public-count-js-extra' src="data:text/javascript;base64,dmFyIHBhcmFtcz17ImFwaV9rZXkiOiJlM2NjNDk1NC05MTVjLTRmZGQtOWIxYi00YWE5MDFhOTkzZmQiLCJob3N0IjoiY2dtYWdvbmxpbmUuY29tIn0=" defer></script>
<script src='https://www.cgmagonline.com/wp-content/plugins/free-comments-for-wordpress-vuukle/public/js/free-comments-for-wordpress-vuukle-public-count.js?ver=5.0.8' id='free-comments-for-wordpress-vuukle-public-count-js' defer data-deferred="1"></script>
<script src='https://www.cgmagonline.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script src='https://www.cgmagonline.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer data-deferred="1"></script>
<script src='https://www.cgmagonline.com/wp-content/plugins/wp-automatic/js/main-front.js?ver=5.9.1' id='wp_automatic_gallery-js' defer data-deferred="1"></script>
<script id='wpp-json' type="application/json">
{"sampling_active":1,"sampling_rate":100,"ajax_url":"https:\/\/www.cgmagonline.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/www.cgmagonline.com\/wp-json\/wordpress-popular-posts","ID":317137,"token":"de3e927dbc","lang":0,"debug":0}
</script>
<script src='https://www.cgmagonline.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.5.1' id='wpp-js-js' defer data-deferred="1"></script>
<link rel="https://api.w.org/" href="https://www.cgmagonline.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.cgmagonline.com/wp-json/wp/v2/posts/317137" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.cgmagonline.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.cgmagonline.com/?p=317137' />
<link rel="alternate" type="application/json+oembed" href="https://www.cgmagonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cgmagonline.com%2Fnews%2Fsteelseries-gear-witch-queen-destiny-2%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cgmagonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cgmagonline.com%2Fnews%2Fsteelseries-gear-witch-queen-destiny-2%2F&#038;format=xml" />
            <link rel="preconnect" href="https://cdn.vuukle.com/">
            <link rel="dns-prefetch" href="https://cdn.vuukle.com/">
            <link rel="dns-prefetch" href="https://api.vuukle.com/">
            <link rel="preconnect" href="https://api.vuukle.com/">
		<script src="https://www.cgmagonline.com/wp-content/uploads/perfmatters/gtagv4.js?id=UA-45129857-1" defer data-deferred="1"></script><script src="data:text/javascript;base64,d2luZG93LmRhdGFMYXllcj13aW5kb3cuZGF0YUxheWVyfHxbXTtmdW5jdGlvbiBndGFnKCl7ZGF0YUxheWVyLnB1c2goYXJndW1lbnRzKX1ndGFnKCJqcyIsbmV3IERhdGUoKSk7Z3RhZygiY29uZmlnIiwiVUEtNDUxMjk4NTctMSIp" defer></script><meta property="og:url" content="https://www.cgmagonline.com/news/steelseries-gear-witch-queen-destiny-2/" /><meta property="og:type" content="article" /><meta property="og:title" content="SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals" /><meta property="og:description" content="Guardian, Destiny 2: The Witch Queen launches today and SteelSeries has you covered, with three acclaimed products in new branded variants." /><meta property="og:image" content="https://www.cgmagonline.com/wp-content/uploads/2022/02/news-steelseries-gears-up-to-battle-the-witch-queen-with-limited-destiny-2-peripherals.jpg" />            <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
            <script async site="cg-mag-online" data-pmdelayedscript="https://kumo.network-n.com/dist/app.js" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<meta name="yandex-verification" content="dc710c1f84cf352b" />
<script type="text/javascript"="async" src="//widgets.outbrain.com/outbrain.js" defer data-deferred="1"></script>



<!-- Schema & Structured Data For WP v1.9.94 - -->
<script type="application/ld+json" class="saswp-schema-markup-output">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</script>

<noscript><style>.lazyload[data-src]{display:none !important;}</style></noscript><style>.lazyload{background-image:none !important;}.lazyload:before{background-image:none !important;}</style><link rel="icon" href="https://cdn.cgmagonline.com/wp-content/uploads/2021/05/cropped-favicon-32x32-1-1.jpg?strip=all&#038;lossy=1&#038;resize=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://cdn.cgmagonline.com/wp-content/uploads/2021/05/cropped-favicon-32x32-1-1.jpg?strip=all&#038;lossy=1&#038;resize=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn.cgmagonline.com/wp-content/uploads/2021/05/cropped-favicon-32x32-1-1.jpg?strip=all&#038;lossy=1&#038;resize=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://cdn.cgmagonline.com/wp-content/uploads/2021/05/cropped-favicon-32x32-1-1.jpg?strip=all&#038;lossy=1&#038;resize=270%2C270&#038;ssl=1" />

<!-- Facebook Open Graph (by Bricks) -->
<meta property="og:url" content="https://www.cgmagonline.com/news/steelseries-gear-witch-queen-destiny-2/" />
<meta property="og:site_name" content="CGMagazine" />
<meta property="og:title" content="SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals" />
<meta property="og:description" content="Guardian, Destiny 2: The Witch Queen launches today and SteelSeries has you covered, with three acclaimed products in new branded variants." />
<meta property="og:image" content="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/news-steelseries-gears-up-to-battle-the-witch-queen-with-limited-destiny-2-peripherals.jpg?strip=all&#038;lossy=1&#038;ssl=1" />
<meta property="og:type" content="article" />

<meta name="viewport" content="width=device-width, user-scalable=yes, initial-scale=1.0, minimum-scale=0.1, maximum-scale=10.0">
<noscript><style>.perfmatters-lazy[data-src]{display:none !important;}</style></noscript><style>.perfmatters-lazy-youtube{position:relative;width:100%;max-width:100%;height:0;padding-bottom:56.23%;overflow:hidden}.perfmatters-lazy-youtube img{position:absolute;top:0;right:0;bottom:0;left:0;display:block;width:100%;max-width:100%;height:auto;margin:auto;border:none;cursor:pointer;transition:.5s all;-webkit-transition:.5s all;-moz-transition:.5s all}.perfmatters-lazy-youtube img:hover{-webkit-filter:brightness(75%)}.perfmatters-lazy-youtube .play{position:absolute;top:50%;left:50%;right:auto;width:68px;height:48px;margin-left:-34px;margin-top:-24px;background:url(https://cdn.cgmagonline.com/wp-content/plugins/perfmatters/img/youtube.svg) no-repeat;background-position:center;background-size:cover;pointer-events:none}.perfmatters-lazy-youtube iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:99}.perfmatters-lazy:not(picture),.perfmatters-lazy>img{opacity:0}.perfmatters-lazy.loaded,.perfmatters-lazy>img.loaded,.perfmatters-lazy[data-was-processed=true]{opacity:1;transition:opacity 500ms}</style></head>

<body class="post-template-default single single-post postid-317137 single-format-standard wp-featherlight-captions bricks-is-frontend wp-embed-responsive">
<script data-cfasync="false">var ewww_webp_supported=false;</script>
		<a class="skip-link" href="#bricks-content" aria-label="Skip to main content">Skip to main content</a>

					<a class="skip-link" href="#bricks-footer" aria-label="Skip to footer">Skip to footer</a>
			
<div id="bricks-site-wrapper" class="bricks-site-wrapper"><header id="bricks-header"><div id="bricks-element-fsoftp" class="bricks-element-fsoftp bricks-container stretch-self"><div id="bricks-element-aehsok" class="bricks-element-aehsok bricks-container"><div id="bricks-element-rqzknh" class="bricks-element-rqzknh bricks-container"><div id="bricks-element-omqyip" class="bricks-element-omqyip bricks-element bricks-element-nav-menu"><nav class="bricks-nav-menu-wrapper tablet_portrait" role="navigation"><ul id="menu-main-menu" class="bricks-nav-menu tablet_portrait" role="menubar"><li id="menu-item-231452" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-231452 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/news/">News</a></li>
<li id="menu-item-231443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231443 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/articles/">Articles</a>
<ul role="menu" class="sub-menu">
	<li id="menu-item-237146" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237146 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/">Features</a></li>
	<li id="menu-item-312860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-312860 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/editorals/">Editorals</a></li>
	<li id="menu-item-237147" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237147 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/previews/">Previews</a></li>
	<li id="menu-item-237218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237218 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/columns/">Columns</a></li>
	<li id="menu-item-238608" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-238608 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/interviews/">Interviews</a></li>
	<li id="menu-item-231447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231447 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/guides/">Game Guides</a></li>
	<li id="menu-item-237145" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237145 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/buyers-guides/">Buyers Guides</a></li>
</ul>
</li>
<li id="menu-item-275241" class="menu-item menu-item-type-post_type_archive menu-item-object-review menu-item-has-children menu-item-275241 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/review/">Reviews</a>
<ul role="menu" class="sub-menu">
	<li id="menu-item-275193" class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275193 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/game/">Game Reviews</a></li>
	<li id="menu-item-275194" class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275194 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/movie/">Movie Reviews</a></li>
	<li id="menu-item-275198" class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275198 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/tabletop/">Tabletop Reviews</a></li>
	<li id="menu-item-275195" class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275195 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/hardware/">Hardware Reviews</a></li>
	<li id="menu-item-275197" class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275197 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/tv-series/">TV Series Reviews</a></li>
	<li id="menu-item-315470" class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-315470 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/comic/">Comic/Book Reviews</a></li>
</ul>
</li>
<li id="menu-item-250665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-250665 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/cgm-family/">Family</a>
<ul role="menu" class="sub-menu">
	<li id="menu-item-251513" class="menu-item menu-item-type-taxonomy menu-item-object-subsite current-post-ancestor current-menu-parent current-post-parent menu-item-251513 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-games/">Video Games</a></li>
	<li id="menu-item-251516" class="menu-item menu-item-type-taxonomy menu-item-object-subsite menu-item-251516 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-toys/">Toys &#038; Games</a></li>
	<li id="menu-item-251514" class="menu-item menu-item-type-taxonomy menu-item-object-subsite current-post-ancestor current-menu-parent current-post-parent menu-item-251514 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-tech/">Technology</a></li>
	<li id="menu-item-251515" class="menu-item menu-item-type-taxonomy menu-item-object-subsite menu-item-251515 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-media/">Movies/TV/Books</a></li>
	<li id="menu-item-251539" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251539 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/a-guide-to-esrb-ratings/">Guide to Game Ratings</a></li>
	<li id="menu-item-257340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-257340 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/columns/parental-no-scope/">Parental No-Scope Column</a></li>
</ul>
</li>
<li id="menu-item-231438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231438 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cgm-tech/">Tech</a></li>
<li id="menu-item-231439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231439 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cgm-backlot/">Entertainment</a></li>
<li id="menu-item-231448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231448 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/magazine-section/">Magazine</a></li>
<li id="menu-item-231445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-231445 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/a-guide-to-esrb-ratings/">More</a>
<ul role="menu" class="sub-menu">
	<li id="menu-item-231449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231449 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cnw-news/">Cision News</a></li>
	<li id="menu-item-308599" class="menu-item menu-item-type-post_type_archive menu-item-object-newswire menu-item-308599 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/newswire/">Newswire</a></li>
</ul>
</li>
<li id="menu-item-255489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-255489 bricks-menu-item" role="menuitem"><a href="https://store.cgmagonline.com/">Store</a></li>
<li id="menu-item-231484" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231484 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/">Podcasts</a>
<ul role="menu" class="sub-menu">
	<li id="menu-item-315460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315460 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/pixels-ink/">Pixels &amp; Ink</a></li>
	<li id="menu-item-315461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315461 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/terrible-warriors/">Terrible Warriors</a></li>
</ul>
</li>
</ul></nav>			<button class="bricks-mobile-menu-toggle tablet_portrait" role="button" aria-haspopup="true" aria-label="Mobile menu" aria-pressed="false">
				<span class="bar-top"></span>
				<span class="bar-center"></span>
				<span class="bar-bottom"></span>
			</button>
			<nav class="bricks-mobile-menu-wrapper left" role="navigation"><ul id="menu-main-menu-1" class="bricks-mobile-menu" role="menubar"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-231452 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231443 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/articles/">Articles</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237146 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/">Features</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-312860 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/editorals/">Editorals</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237147 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/previews/">Previews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237218 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-238608 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/interviews/">Interviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231447 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/guides/">Game Guides</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237145 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/buyers-guides/">Buyers Guides</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type_archive menu-item-object-review menu-item-has-children menu-item-275241 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/review/">Reviews</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275193 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/game/">Game Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275194 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/movie/">Movie Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275198 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/tabletop/">Tabletop Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275195 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/hardware/">Hardware Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275197 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/tv-series/">TV Series Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-315470 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/comic/">Comic/Book Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-250665 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/cgm-family/">Family</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite current-post-ancestor current-menu-parent current-post-parent menu-item-251513 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-games/">Video Games</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite menu-item-251516 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-toys/">Toys &#038; Games</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite current-post-ancestor current-menu-parent current-post-parent menu-item-251514 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-tech/">Technology</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite menu-item-251515 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-media/">Movies/TV/Books</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251539 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/a-guide-to-esrb-ratings/">Guide to Game Ratings</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-257340 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/columns/parental-no-scope/">Parental No-Scope Column</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231438 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cgm-tech/">Tech</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231439 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cgm-backlot/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231448 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/magazine-section/">Magazine</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-231445 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/a-guide-to-esrb-ratings/">More</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231449 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cnw-news/">Cision News</a></li>
	<li class="menu-item menu-item-type-post_type_archive menu-item-object-newswire menu-item-308599 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/newswire/">Newswire</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-255489 bricks-menu-item" role="menuitem"><a href="https://store.cgmagonline.com/">Store</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231484 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/">Podcasts</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315460 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/pixels-ink/">Pixels &amp; Ink</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315461 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/terrible-warriors/">Terrible Warriors</a></li>
</ul>
</li>
</ul></nav><div class="bricks-mobile-menu-overlay"></div></div><div id="bricks-element-fmkmnc" class="bricks-element-fmkmnc bricks-element bricks-element-logo"><a href="https://www.cgmagonline.com"><img width="148" height="49" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAJQAAAAxAQAAAAAUlr0kAAAAAnRSTlMAAHaTzTgAAAAQSURBVHgBYxgFo2AUDCsAAAPUAAGk18RwAAAAAElFTkSuQmCC" class="bricks-site-logo css-filter lazyload" alt="CGMagazine"   data-src="https://cdn.cgmagonline.com/wp-content/uploads/2021/03/cgm-tech-logo.png?strip=all&lossy=1&ssl=1" decoding="async" data-srcset="https://cdn.cgmagonline.com/wp-content/uploads/2021/03/cgm-tech-logo.png?strip=all&amp;lossy=1&amp;ssl=1 148w, https://cdn.cgmagonline.com/wp-content/uploads/2021/03/cgm-tech-logo-20x7.png?strip=all&amp;lossy=1&amp;ssl=1 20w" data-sizes="auto" /><noscript><img width="148" height="49" src="https://cdn.cgmagonline.com/wp-content/uploads/2021/03/cgm-tech-logo.png?strip=all&amp;lossy=1&amp;ssl=1" class="bricks-site-logo css-filter" alt="CGMagazine" srcset="https://cdn.cgmagonline.com/wp-content/uploads/2021/03/cgm-tech-logo.png?strip=all&amp;lossy=1&amp;ssl=1 148w, https://cdn.cgmagonline.com/wp-content/uploads/2021/03/cgm-tech-logo-20x7.png?strip=all&amp;lossy=1&amp;ssl=1 20w" sizes="(max-width: 148px) 100vw, 148px" data-eio="l" /></noscript></a></div><div id="bricks-element-zroscn" class="bricks-element-zroscn bricks-element bricks-element-nav-menu"><nav class="bricks-nav-menu-wrapper tablet_portrait" role="navigation"><ul id="menu-main-menu-2" class="bricks-nav-menu tablet_portrait" role="menubar"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-231452 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231443 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/articles/">Articles</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237146 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/">Features</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-312860 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/editorals/">Editorals</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237147 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/previews/">Previews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237218 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-238608 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/interviews/">Interviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231447 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/guides/">Game Guides</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237145 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/buyers-guides/">Buyers Guides</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type_archive menu-item-object-review menu-item-has-children menu-item-275241 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/review/">Reviews</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275193 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/game/">Game Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275194 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/movie/">Movie Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275198 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/tabletop/">Tabletop Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275195 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/hardware/">Hardware Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275197 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/tv-series/">TV Series Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-315470 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/comic/">Comic/Book Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-250665 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/cgm-family/">Family</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite current-post-ancestor current-menu-parent current-post-parent menu-item-251513 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-games/">Video Games</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite menu-item-251516 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-toys/">Toys &#038; Games</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite current-post-ancestor current-menu-parent current-post-parent menu-item-251514 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-tech/">Technology</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite menu-item-251515 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-media/">Movies/TV/Books</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251539 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/a-guide-to-esrb-ratings/">Guide to Game Ratings</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-257340 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/columns/parental-no-scope/">Parental No-Scope Column</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231438 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cgm-tech/">Tech</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231439 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cgm-backlot/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231448 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/magazine-section/">Magazine</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-231445 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/a-guide-to-esrb-ratings/">More</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231449 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cnw-news/">Cision News</a></li>
	<li class="menu-item menu-item-type-post_type_archive menu-item-object-newswire menu-item-308599 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/newswire/">Newswire</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-255489 bricks-menu-item" role="menuitem"><a href="https://store.cgmagonline.com/">Store</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231484 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/">Podcasts</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315460 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/pixels-ink/">Pixels &amp; Ink</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315461 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/terrible-warriors/">Terrible Warriors</a></li>
</ul>
</li>
</ul></nav>			<button class="bricks-mobile-menu-toggle tablet_portrait" role="button" aria-haspopup="true" aria-label="Mobile menu" aria-pressed="false">
				<span class="bar-top"></span>
				<span class="bar-center"></span>
				<span class="bar-bottom"></span>
			</button>
			<nav class="bricks-mobile-menu-wrapper left" role="navigation"><ul id="menu-main-menu-3" class="bricks-mobile-menu" role="menubar"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-231452 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231443 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/articles/">Articles</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237146 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/">Features</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-312860 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/editorals/">Editorals</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237147 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/previews/">Previews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237218 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-238608 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/interviews/">Interviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231447 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/guides/">Game Guides</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237145 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/buyers-guides/">Buyers Guides</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type_archive menu-item-object-review menu-item-has-children menu-item-275241 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/review/">Reviews</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275193 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/game/">Game Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275194 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/movie/">Movie Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275198 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/tabletop/">Tabletop Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275195 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/hardware/">Hardware Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-275197 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/tv-series/">TV Series Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-review-type menu-item-315470 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review/comic/">Comic/Book Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-250665 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/cgm-family/">Family</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite current-post-ancestor current-menu-parent current-post-parent menu-item-251513 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-games/">Video Games</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite menu-item-251516 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-toys/">Toys &#038; Games</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite current-post-ancestor current-menu-parent current-post-parent menu-item-251514 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-tech/">Technology</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-subsite menu-item-251515 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/subsite/family-media/">Movies/TV/Books</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251539 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/a-guide-to-esrb-ratings/">Guide to Game Ratings</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-257340 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/articles/columns/parental-no-scope/">Parental No-Scope Column</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231438 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cgm-tech/">Tech</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231439 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cgm-backlot/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231448 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/magazine-section/">Magazine</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-231445 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/articles/features/a-guide-to-esrb-ratings/">More</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231449 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/cnw-news/">Cision News</a></li>
	<li class="menu-item menu-item-type-post_type_archive menu-item-object-newswire menu-item-308599 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/newswire/">Newswire</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-255489 bricks-menu-item" role="menuitem"><a href="https://store.cgmagonline.com/">Store</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231484 bricks-menu-item" aria-haspopup="true" aria-expanded="false" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/">Podcasts</a>
<ul role="menu" class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315460 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/pixels-ink/">Pixels &amp; Ink</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315461 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/podcasts/terrible-warriors/">Terrible Warriors</a></li>
</ul>
</li>
</ul></nav><div class="bricks-mobile-menu-overlay"></div></div><div id="bricks-element-brudhe" class="bricks-element-brudhe bricks-element bricks-element-search"><div class="bricks-search-icon overlay-trigger"><i class="ion-ios-search"></i></div>
			<div class="bricks-search-overlay">
				<div class="bricks-search-inner">
					<h4 class="title">Search site</h4>
					
<form role="search" method="get" class="bricks-search-form" action="https://www.cgmagonline.com/">
	<label class="screen-reader-text"><span>Search ...</span></label>
	<input type="search" placeholder="Search ..." value="" name="s" />

	
	<button type="submit" class="screen-reader-text search-submit"><span>Search</span></button>
</form>
				</div>

				<span class="close">×</span>			</div>
			</div></div></div></div><div id="bricks-element-xdkdvo" class="bricks-element-xdkdvo bricks-container"><div id="bricks-element-ccqzuw" class="bricks-element-ccqzuw bricks-element bricks-element-shortcode"><div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_lb1"></div>
<div id="nn_mobile_lb1"></div></div>
</div></div></header><main id="bricks-content"><div id="bricks-element-jkfnsf" class="bricks-element-jkfnsf bricks-container root"><div id="bricks-element-kwfjmh" class="bricks-element-kwfjmh bricks-element bricks-element-post-title"><h1 class="post-title">SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals</h1></div><div id="bricks-element-xwkitv" class="bricks-element-xwkitv bricks-container"><div id="bricks-element-fvmhau" class="bricks-element-fvmhau bricks-element bricks-element-post-meta"><div class="post-meta"><span class="item">Fight the Hive with style</span></div></div></div><div id="bricks-element-vnnnuu" class="bricks-element-vnnnuu bricks-container"><div id="bricks-element-acdklj" class="bricks-element-acdklj bricks-container"><div id="bricks-element-oezuwq" class="bricks-element-oezuwq bricks-container"><div id="bricks-element-vlwngn" class="bricks-element-vlwngn bricks-container"><div id="bricks-element-vkstym" class="bricks-element-vkstym bricks-element bricks-element-shortcode"><a href="https://www.cgmagonline.com/author/chrisdehoog/" title="Posts by Chris De Hoog" class="author url fn" rel="author">Chris De Hoog</a> | Feb 22, 2022</div><div id="cgmshare" class="bricks-element-hhxlhj bricks-container"><div id="bricks-element-hezgno" class="bricks-element-hezgno bricks-element bricks-element-code"><div class='vuukle-powerbar'></div></div></div></div></div><div id="bricks-element-dzqedy" class="bricks-element-dzqedy bricks-container"><div id="bricks-element-rghgua" class="bricks-element-rghgua bricks-container"><div id="bricks-element-utzzvz" class="bricks-element-utzzvz bricks-element bricks-element-shortcode"><div class='brandoftheyear'>
<img width="150" height="150" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAMgAAADIAQAAAACFI5MzAAAAAnRSTlMAAHaTzTgAAAAcSURBVFjD7cGBAAAAAMOg+VNf4QBVAQAAAAB8BhRQAAEAnyMVAAAAAElFTkSuQmCC" class="post-thumbnail css-filter size-thumbnail lazyload" alt="Brand of the Year" data-src="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/brandoftheyear2021.png?strip=all&lossy=1&ssl=1" decoding="async"><noscript><img width="150" height="150" src="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/brandoftheyear2021.png?strip=all&lossy=1&ssl=1" class="post-thumbnail css-filter size-thumbnail" alt="Brand of the Year" data-eio="l"></noscript>
	</div>
	</div></div></div><div id="bricks-element-jbdjzh" class="bricks-element-jbdjzh bricks-container"><div id="bricks-element-wziqvj" class="bricks-element-wziqvj bricks-container"><div id="bricks-element-mbnooz" class="bricks-element-mbnooz bricks-element bricks-element-post-content">
<h4 id="guardian-destiny-2-the-witch-queen-launches-today-and-steelseries-has-you-covered-with-three-acclaimed-products-in-new-branded-variants">Guardian, <em>Destiny 2: The Witch Queen</em> launches today and SteelSeries has you covered, with three acclaimed products in new branded variants.</h4>



<!--more-->



<p>Once we hit the usual weekly reset time today (12PM EST), the next chapter of <em><a href='https://www.cgmagonline.com/news/destiny-2-trials-of-osiris/' title='Destiny 2 Trials of Osiris is Back and Revamped for Season 15' >Destiny 2</a></em> will truly begin as <a href="https://www.bungie.net/7/en/Destiny/WitchQueen" target="_blank" rel="noopener"><em>The Witch Queen</em> expansion goes live</a>. As Guardians prepare to take the fight to Savathun on her Throne <a href='https://www.cgmagonline.com/news/world-of-tanks-receive-free-story-dlc/' title='World of Tanks to Receive Free Spoils of War Ambitious Story DLC' >World</a> and put an end to her vile Light-bearing henchmen, <a href="https://steelseries.com/destiny-collection" target="_blank" rel="noopener">SteelSeries has a trio of acclaimed products</a> with the <a href='https://www.cgmagonline.com/articles/features/how-to-develop-your-own-game/' title='How To Develop Your Own Game' >game</a>&#8217;s iconography to inspire you.</p>



<p>The Arctis 1 Headset, <a href="https://www.amazon.com/SteelSeries-PrismSync-Lighting-Programmable-Buttons/dp/B09S6TLCHD/?tag=cgmagazine06-20" target="_blank" rel="noopener">Rival 5 Gaming Mouse</a>, <a href="https://www.amazon.com/SteelSeries-QcK-Gaming-Surface-Optimized/dp/B09S6RR54T/?tag=cgmagazine06-20" target="_blank" rel="noopener">QcK Prism XL Mousepad</a>, and speaker plates for the Arctis Pro headset have all been given a white-and-silver makeover to reflect <em><a href='https://www.cgmagonline.com/news/destiny-2-trials-of-osiris/' title='Destiny 2 Trials of Osiris is Back and Revamped for Season 15' >Destiny 2</a></em>&#8216;s aesthetic, reminiscent of the Steelbook design from the <a href='https://www.cgmagonline.com/articles/features/how-to-develop-your-own-game/' title='How To Develop Your Own Game' >game</a>&#8217;s Limited Edition. Class icons and the <a href='https://www.cgmagonline.com/articles/columns/parental-no-scope/children-favourite-franchises/' title='Introducing Your Children to Your Favourite Franchises' >franchise</a>&#8217;s iconic geometric designs are etched on each of these components, making them look like they&#8217;ve been lifted out of the loading screens and placed on your desktop.</p><div class='code-block code-block-6' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_mpu3"></div>
<div id="nn_mobile_mpu3"></div></div>




<figure class="wp-block-gallery aligncenter has-nested-images columns-default is-cropped">
<figure class="wp-block-image size-large"><img width="1280" height="720" data-id="317149" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABQAAAALQAQAAAADnBuD7AAAAAnRSTlMAAHaTzTgAAACHSURBVHja7cExAQAAAMKg9U9tCU+gAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAHgaxN8AAZz3lEoAAAAASUVORK5CYII=" alt="Steelseries And Bungie Have Teamed Up To Deliver A Trio Of Gaming Peripherals Meant To Elevate Your Game And Your Desktop." class="wp-image-317149 lazyload"   title="Steelseries Gears Up To Battle The Witch Queen With Limited Destiny 2 Peripherals" data-src="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-1280x720.jpg?strip=all&lossy=1&ssl=1" decoding="async" data-srcset="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-1280x720.jpg?strip=all&amp;lossy=1&amp;ssl=1 1280w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-300x169.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-150x84.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-768x432.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-1200x675.jpg?strip=all&amp;lossy=1&amp;ssl=1 1200w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-600x338.jpg?strip=all&amp;lossy=1&amp;ssl=1 600w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse.jpg?strip=all&amp;lossy=1&amp;w=384&amp;ssl=1 384w" data-sizes="auto"><noscript><img width="1280" height="720" data-id="317149" src="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-1280x720.jpg?strip=all&lossy=1&ssl=1" alt="Steelseries And Bungie Have Teamed Up To Deliver A Trio Of Gaming Peripherals Meant To Elevate Your Game And Your Desktop." class="wp-image-317149" srcset="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-1280x720.jpg?strip=all&amp;lossy=1&amp;ssl=1 1280w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-300x169.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-150x84.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-768x432.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-1200x675.jpg?strip=all&amp;lossy=1&amp;ssl=1 1200w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse-600x338.jpg?strip=all&amp;lossy=1&amp;ssl=1 600w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mouse.jpg?strip=all&amp;lossy=1&amp;w=384&amp;ssl=1 384w" sizes="(max-width: 1280px) 100vw, 1280px" title="Steelseries Gears Up To Battle The Witch Queen With Limited Destiny 2 Peripherals" data-eio="l"></noscript><figcaption>Rival 5: Destiny Edition</figcaption></figure>



<figure class="wp-block-image size-large"><img width="720" height="720" data-id="317150" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAtAAAALQAQAAAACRLHoxAAAAAnRSTlMAAHaTzTgAAABVSURBVHja7cEBAQAAAIIg/69uSEABAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAADwaP/wAAHdGfkMAAAAAElFTkSuQmCC" alt="Steelseries And Bungie Have Teamed Up To Deliver A Trio Of Gaming Peripherals Meant To Elevate Your Game And Your Desktop." class="wp-image-317150 lazyload"   title="Steelseries Gears Up To Battle The Witch Queen With Limited Destiny 2 Peripherals" data-src="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-720x720.jpg?strip=all&lossy=1&ssl=1" decoding="async" data-srcset="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-720x720.jpg?strip=all&amp;lossy=1&amp;ssl=1 720w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-300x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-768x768.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-162x162.jpg?strip=all&amp;lossy=1&amp;ssl=1 162w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-1200x1200.jpg?strip=all&amp;lossy=1&amp;ssl=1 1200w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-600x600.jpg?strip=all&amp;lossy=1&amp;ssl=1 600w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset.jpg?strip=all&amp;lossy=1&amp;w=384&amp;ssl=1 384w" data-sizes="auto"><noscript><img width="720" height="720" data-id="317150" src="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-720x720.jpg?strip=all&lossy=1&ssl=1" alt="Steelseries And Bungie Have Teamed Up To Deliver A Trio Of Gaming Peripherals Meant To Elevate Your Game And Your Desktop." class="wp-image-317150" srcset="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-720x720.jpg?strip=all&amp;lossy=1&amp;ssl=1 720w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-300x300.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-150x150.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-768x768.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-162x162.jpg?strip=all&amp;lossy=1&amp;ssl=1 162w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-1200x1200.jpg?strip=all&amp;lossy=1&amp;ssl=1 1200w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset-600x600.jpg?strip=all&amp;lossy=1&amp;ssl=1 600w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-headset.jpg?strip=all&amp;lossy=1&amp;w=384&amp;ssl=1 384w" sizes="(max-width: 720px) 100vw, 720px" title="Steelseries Gears Up To Battle The Witch Queen With Limited Destiny 2 Peripherals" data-eio="l"></noscript><figcaption>Arctis 1: Destiny Edition</figcaption></figure>



<figure class="wp-block-image size-large"><img width="1280" height="720" data-id="317151" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABQAAAALQAQAAAADnBuD7AAAAAnRSTlMAAHaTzTgAAACHSURBVHja7cExAQAAAMKg9U9tCU+gAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAHgaxN8AAZz3lEoAAAAASUVORK5CYII=" alt="Steelseries And Bungie Have Teamed Up To Deliver A Trio Of Gaming Peripherals Meant To Elevate Your Game And Your Desktop." class="wp-image-317151 lazyload"   title="Steelseries Gears Up To Battle The Witch Queen With Limited Destiny 2 Peripherals" data-src="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-1280x720.jpg?strip=all&lossy=1&ssl=1" decoding="async" data-srcset="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-1280x720.jpg?strip=all&amp;lossy=1&amp;ssl=1 1280w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-300x169.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-150x84.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-768x432.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-1200x675.jpg?strip=all&amp;lossy=1&amp;ssl=1 1200w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-600x338.jpg?strip=all&amp;lossy=1&amp;ssl=1 600w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad.jpg?strip=all&amp;lossy=1&amp;w=384&amp;ssl=1 384w" data-sizes="auto"><noscript><img width="1280" height="720" data-id="317151" src="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-1280x720.jpg?strip=all&lossy=1&ssl=1" alt="Steelseries And Bungie Have Teamed Up To Deliver A Trio Of Gaming Peripherals Meant To Elevate Your Game And Your Desktop." class="wp-image-317151" srcset="https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-1280x720.jpg?strip=all&amp;lossy=1&amp;ssl=1 1280w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-300x169.jpg?strip=all&amp;lossy=1&amp;ssl=1 300w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-150x84.jpg?strip=all&amp;lossy=1&amp;ssl=1 150w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-768x432.jpg?strip=all&amp;lossy=1&amp;ssl=1 768w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-1200x675.jpg?strip=all&amp;lossy=1&amp;ssl=1 1200w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad-600x338.jpg?strip=all&amp;lossy=1&amp;ssl=1 600w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad.jpg?strip=all&amp;lossy=1&amp;ssl=1 1536w, https://cdn.cgmagonline.com/wp-content/uploads/2022/02/steelseries-destiny-mousepad.jpg?strip=all&amp;lossy=1&amp;w=384&amp;ssl=1 384w" sizes="(max-width: 1280px) 100vw, 1280px" title="Steelseries Gears Up To Battle The Witch Queen With Limited Destiny 2 Peripherals" data-eio="l"></noscript><figcaption>QcK Prism XL: Destiny Edition</figcaption></figure>
<figcaption class="blocks-gallery-caption"><a href='https://www.cgmagonline.com/news/steelseries-to-expand-new-gn-support/' title='SteelSeries to Expand Its Reach with New GN Support' >SteelSeries</a> and <a href='https://www.cgmagonline.com/news/sony-acquires-bungie-for-3-6-billion/' title='Sony Acquires Destiny Developer, Bungie for $3.6 Billion' >Bungie</a> have teamed up to deliver a trio of <a href='https://www.cgmagonline.com/articles/features/changes-gaming-industry-last-decade/' title='The Biggest Changes in the Gaming Industry in the Last Decade' >gaming</a> <a href='https://www.cgmagonline.com/news/steelseries-announces-brand-new-gaming-peripherals/' title='SteelSeries Reveals Brand New Gaming Peripherals' >peripherals</a> meant to elevate your <a href='https://www.cgmagonline.com/articles/features/how-to-develop-your-own-game/' title='How To Develop Your Own Game' >game</a> and your desktop.</figcaption></figure>



<p>Foremost among the collection might be <a href="https://www.cgmagonline.com/review/hardware/steelseries-rival-5-review/">the Rival 5 mouse</a>. <a href="https://www.cgmagonline.com/articles/features/best-wired-mouse-2021/">Named CGM&#8217;s Wired Mouse of the Year for 2021</a>, <a href='https://www.cgmagonline.com/articles/features/it-what-could-we-expect-in-part-2/' title='It Part 2: Older and Pennywise-r' >it</a> features 9 programmable buttons, including a toggle <a href='https://www.cgmagonline.com/news/nippon-ichi-ceo-teases-switch-development/' title='Nippon Ichi CEO Teases Switch Development' >switch</a> on its signature 5-button quick action side panel. The <a href="https://www.amazon.com/SteelSeries-PrismSync-Lighting-Programmable-Buttons/dp/B09S6TLCHD/?tag=cgmagazine06-20" target="_blank" rel="noopener">Rival 5: Destiny Edition</a> multi-<a href='https://www.cgmagonline.com/articles/features/best-of-2016-genre-films/' title='Best of 2016: Genre Films' >genre</a> <a href='https://www.cgmagonline.com/articles/features/changes-gaming-industry-last-decade/' title='The Biggest Changes in the Gaming Industry in the Last Decade' >gaming</a> mouse retails for $74.99 USD and includes a timed-exclusive Exotic emote, &#8220;Viral Celebration.&#8221;</p>



<p>Get deeper into the action with the Arctis 1. This <a href='https://www.cgmagonline.com/news/universal-expanding-agreements-twitch/' title='Universal is Expanding Agreements with Amazon Music and Twitch' >universal</a> headset includes <a href='https://www.cgmagonline.com/news/steelseries-to-expand-new-gn-support/' title='SteelSeries to Expand Its Reach with New GN Support' >SteelSeries</a>&#8217; signature <a href="https://www.cgmagonline.com/review/hardware/steelseries-arctis-7-hardware-review/" data-type="review" data-id="93752">Arctis</a> drivers and detachable ClearCast microphone, allowing you to communicate with your fireteam and hear your enemies coming. Whichever platform you play <em><a href='https://www.cgmagonline.com/news/destiny-2-trials-of-osiris/' title='Destiny 2 Trials of Osiris is Back and Revamped for Season 15' >Destiny 2</a></em> on, you&#8217;ll be prepared in style without breaking the bank at a comparable $59.99 USD. The Arctis 1: Destiny Edition also includes the &#8220;Viral Celebration&#8221; emote as a timed-exclusive.</p>



<p>Put the face of the Traveler itself on your desk with the <a href="https://www.amazon.com/SteelSeries-QcK-Gaming-Surface-Optimized/dp/B09S6RR54T/?tag=cgmagazine06-20" target="_blank" rel="noopener">QcK Prism XL: Destiny Edition.</a> <a href='https://www.cgmagonline.com/news/steelseries-to-expand-new-gn-support/' title='SteelSeries to Expand Its Reach with New GN Support' >SteelSeries</a> broke its teeth in the industry by making <a href='https://www.cgmagonline.com/articles/features/changes-gaming-industry-last-decade/' title='The Biggest Changes in the Gaming Industry in the Last Decade' >gaming</a> mousepads and their pedigree still shines through today. Their micro-woven cloth mousepads are optimized for low and high DPI tracking movements. Measuring 35.4 x 11.8 inches, it retails for $69.99 USD and includes the exclusive Existential Unfoldment emblem.</p><div class='code-block code-block-7' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_mpu1"></div>
<div id="nn_mobile_mpu1"></div></div>




<p>And what would gaming peripherals be without a little RGB? Using SteelSeries&#8217; GG software, you can customize your mousepad and mouse to glow in rhythm with any other compatible peripherals, even responding to in-game cues.</p>



<figure class="wp-block-embed aligncenter is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<div class="entry-content-asset"><div class="perfmatters-lazy-youtube" data-src="https://www.youtube.com/embed/PYM7KDrx_Ho" data-id="PYM7KDrx_Ho" data-query="feature=oembed" onclick="perfmattersLazyLoadYouTube(this);"><div><img class="perfmatters-lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20480%20360%3E%3C/svg%3E" data-src="https://i.ytimg.com/vi/PYM7KDrx_Ho/hqdefault.jpg" alt="YouTube video" width="480" height="360" data-pin-nopin="true"><div class="play"></div></div></div><noscript><iframe title="Destiny 2: The Witch Queen - Launch Trailer" width="500" height="281" src="https://www.youtube.com/embed/PYM7KDrx_Ho?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></noscript></div>
</div></figure>



<p>Taking this collaboration further, <a href="https://www.cgmagonline.com/news/sony-acquires-bungie-for-3-6-billion/">sound designers at Bungie</a> have created a custom equalizer preset for SteelSeries Sonar. This new audio software will improve sound customization for PC players, enabling immersive spatial audio, ChatMix, and 7.1 virtual surround sound. Sonar&#8217;s <a href='https://www.cgmagonline.com/articles/features/early-access-still-good-idea/' title='Early Access is Still a Good Idea' >early access</a> version went live last week ahead of its summer release, when it will integrate into the existing SteelSeries GG software ecosystem.</p>



<p>All items in the <a href="https://steelseries.com/destiny-collection" target="_blank" rel="noopener">Destiny x SteelSeries line are now available through the company&#8217;s website</a> or retail partners. Meanwhile, the long-awaited <em>Destiny 2: The Witch Queen</em> goes live today, following in the footsteps of November 2020&#8217;s <em><a href="https://www.cgmagonline.com/review/game/destiny-2-beyond-light-review/">Beyond Light</a></em>. <a href='https://www.cgmagonline.com/news/pixel-art-thriller-stay-coming-out-on-ps4-and-the-switch/' title='Pixel Art Thriller STAY Coming Out for PS4 and the Switch' >Stay</a> tuned to <a href='https://www.cgmagonline.com/magazine-section/celebrate-torontos-birthday-cgm/' title='Celebrate Toronto\'s Birthday With CGM!' >CGMagazine</a> over the next week as our review takes shape, or check out <a href="https://www.cgmagonline.com/news/brand-of-the-year-2021-steelseries/">why we named SteelSeries our inaugural Brand of the Year in 2021</a>.</p>
<!-- AI CONTENT END 1 -->
</div><div id="bricks-element-ajmpoq" class="bricks-element-ajmpoq bricks-element bricks-element-shortcode">		<style>
.sponsored-post {
    padding-bottom: 20px;
    font-size: 15px;
    font-style: italic;
    font-weight: 600;
}
</style></div><div id="bricks-element-tbmkgx" class="bricks-element-tbmkgx bricks-element bricks-element-post-meta"><div class="post-meta"><span class="item"><Strong>File Under: </strong> <a href="https://www.cgmagonline.com/tag/bungie/">Bungie</a>, <a href="https://www.cgmagonline.com/tag/steelseries/">Steelseries</a></span></div></div><div id="bricks-element-vnbegl" class="bricks-element-vnbegl bricks-container"><div id="bricks-element-nvypby" class="bricks-element-nvypby bricks-element bricks-element-code"><div id="nn_player1"></div></div></div><div id="bricks-element-vrbfcv" class="bricks-element-vrbfcv bricks-container"><div id="bricks-element-cesswg" class="bricks-element-cesswg bricks-element bricks-element-code"><div class="OUTBRAIN" data-widget-id="GS_5" data-src="https://www.cgmagonline.com/news/steelseries-gear-witch-queen-destiny-2/"></div></div><div id="cgmcomment" class="bricks-element-japkan bricks-container"><div id="bricks-element-unebzo" class="bricks-element-unebzo bricks-element bricks-element-code"><div id="vuukle-comments"></div></div></div></div></div></div></div><div id="bricks-element-xeahbs" class="bricks-element-xeahbs bricks-container"><div id="bricks-element-zvkpxx" class="bricks-element-zvkpxx bricks-element bricks-element-sidebar">			<ul id="sidebar-news_sidebar">
				<li class="bricks-widget-wrapper"><div data-conversation-spotlight="" data-spotlight-sidebar=""></div></li><li class="bricks-widget-wrapper"><div id="predict_fl676f"></div><script type="text/javascript" src="https://content.predictinteractive.com/embeds/placement.js?z=fl676f&div_id=predict_fl676f" defer data-deferred="1"></script>
<div id="predict_xy45lf"></div>
<div id="div-gpt-ad-1497448474263-3"></div>
<script data-pmdelayedscript="data:text/javascript;base64,aWYoIXdpbmRvdy52dXVrbGVMb2FkZWQpdHJ5e3dpbmRvdy50b3AudnV1a2xlTG9hZGVyKCksd2luZG93LnZ1dWtsZUxvYWRlZD0xfWNhdGNoKGUpe31pZighd2luZG93LnZ1dWtsZVBsYXllckNvbXBvbmVudCYmIXdpbmRvdy52dXVrbGVMb2FkZWQpe3dpbmRvdy52dXVrbGVMb2FkZWQ9MTtsZXQgZT1kb2N1bWVudC5jcmVhdGVFbGVtZW50KCJzY3JpcHQiKTtlLnR5cGU9InRleHQvamF2YXNjcmlwdCIsZS5zcmM9Imh0dHBzOi8vY2RuLnZ1dWtsZS5jb20vc3RhdGljL3ByZWJpZDMuanMiLChkb2N1bWVudC5oZWFkfHxkb2N1bWVudC5kb2N1bWVudEVsZW1lbnQpLmFwcGVuZENoaWxkKGUpfXdpbmRvdy52dXVrbGVoYj13aW5kb3cudnV1a2xlaGJ8fHt9LHdpbmRvdy52dXVrbGVoYi5xdWU9d2luZG93LnZ1dWtsZWhiLnF1ZXx8W10sd2luZG93LnZ1dWtsZWhiLnF1ZS5wdXNoKGZ1bmN0aW9uKCl7d2luZG93LnZ1dWtsZWhiLnZJbml0U2xvdCYmd2luZG93LnZ1dWtsZWhiLnZJbml0U2xvdCgiZGl2LWdwdC1hZC0xNDk3NDQ4NDc0MjYzLTMiKX0pOwo=" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="text/javascript" src="https://content.predictinteractive.com/embeds/placement.js?z=xy45lf&div_id=predict_xy45lf" defer data-deferred="1"></script></li>			</ul>
			</div></div></div></div></main><footer id="bricks-footer"><div id="bricks-element-krqaqv" class="bricks-element-krqaqv bricks-container"><div id="bricks-element-pxacds" class="bricks-element-pxacds bricks-element bricks-element-shortcode"><div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_lb3"></div></div>
</div></div><div id="bricks-element-mnvmyi" class="bricks-element-mnvmyi bricks-container"><div id="bricks-element-hadyjt" class="bricks-element-hadyjt bricks-container"><div id="bricks-element-njxnye" class="bricks-element-njxnye bricks-container"><div id="bricks-element-mlqkqc" class="bricks-element-mlqkqc bricks-element bricks-element-image"><div class="image-wrapper"><img width="162" height="96" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAKIAAABgAQAAAAC2qZQJAAAAAnRSTlMAAHaTzTgAAAAYSURBVHgBYxgFo2AUjIJRMApGwSggEQAACEAAAXUHUCwAAAAASUVORK5CYII=" class="post-thumbnail css-filter size-thumbnail-small lazyload" alt="" id="image-192309"   data-src="https://cdn.cgmagonline.com/wp-content/uploads/2020/07/CGM_LOGO_White-smallX2.png?strip=all&lossy=1&resize=162%2C96&ssl=1" decoding="async" data-srcset="https://cdn.cgmagonline.com/wp-content/uploads/2020/07/CGM_LOGO_White-smallX2-162x96.png?strip=all&amp;lossy=1&amp;ssl=1 162w, https://cdn.cgmagonline.com/wp-content/uploads/2020/07/CGM_LOGO_White-smallX2.png?strip=all&amp;lossy=1&amp;zoom=0.4&amp;resize=162%2C96&amp;ssl=1 64w" data-sizes="auto" /><noscript><img width="162" height="96" src="https://cdn.cgmagonline.com/wp-content/uploads/2020/07/CGM_LOGO_White-smallX2.png?strip=all&amp;lossy=1&amp;resize=162%2C96&amp;ssl=1" class="post-thumbnail css-filter size-thumbnail-small" alt="" id="image-192309" srcset="https://cdn.cgmagonline.com/wp-content/uploads/2020/07/CGM_LOGO_White-smallX2-162x96.png?strip=all&amp;lossy=1&amp;ssl=1 162w, https://cdn.cgmagonline.com/wp-content/uploads/2020/07/CGM_LOGO_White-smallX2.png?strip=all&amp;lossy=1&amp;zoom=0.4&amp;resize=162%2C96&amp;ssl=1 64w" sizes="(max-width: 162px) 100vw, 162px" data-eio="l" /></noscript></div></div><div id="bricks-element-vvilfn" class="bricks-element-vvilfn bricks-element bricks-element-text"><div class="text-wrapper"><p><a href='https://www.cgmagonline.com/magazine-section/celebrate-torontos-birthday-cgm/' title='Celebrate Toronto\'s Birthday With CGM!' >CGMagazine</a> is  convergance of cutlure and media, looking at <a href='https://www.cgmagonline.com/articles/features/changes-gaming-industry-last-decade/' title='The Biggest Changes in the Gaming Industry in the Last Decade' >gaming</a>, film, <a href='https://www.cgmagonline.com/news/modiphius-and-paradox-collide-to-bring-vampire-the-masquerade-5th-edition/' title='Modiphius and Paradox Collide to Bring Vampire: The Masquerade 5th Edition' >tabletop</a>, and technology. With features, reviews, articles and news, <a href='https://www.cgmagonline.com/articles/features/cgm-monthly-top-10-reviews-november-2021/' title='CGM Monthly Top 10 Reviews: November 2021' >CGM</a> is here to keep you informed and in the know on everything new and exciting. </p>
<!-- AI CONTENT END 2 -->
</div></div><div id="bricks-element-ignujv" class="bricks-element-ignujv bricks-element bricks-element-social-icons">
		<ul class="social-icons">
			<li class="repeater-item"><a class="bricks-link-type-external" href="https://twitter.com/cgmagonline" rel="nofollow" target="_blank"><i class="fab fa-twitter"></i></a></li><li class="repeater-item"><a class="bricks-link-type-external" href="https://www.facebook.com/ComicsGamingmagazine/" rel="nofollow" target="_blank"><i class="fab fa-facebook-square"></i></a></li><li class="repeater-item"><a class="bricks-link-type-external" href="https://www.instagram.com/cgmagonline/" rel="nofollow" target="_blank"><i class="fab fa-instagram"></i></a></li><li class="repeater-item"><a class="bricks-link-type-external" href="https://www.youtube.com/user/channelcgm" rel="nofollow" target="_blank"><i class="fab fa-youtube"></i></a></li><li class="repeater-item"><a class="bricks-link-type-external" href="https://flipboard.com/@CGMOnline" rel="nofollow" target="_blank"><i class="fab fa-flipboard"></i></a></li>		</ul>

		</div></div><div id="bricks-element-ezgxnn" class="bricks-element-ezgxnn bricks-container"><div id="bricks-element-kibwyi" class="bricks-element-kibwyi bricks-container"><div id="bricks-element-ypadab" class="bricks-element-ypadab bricks-element bricks-element-text"><div class="text-wrapper"><p>CONTACT</p>
<!-- AI CONTENT END 3 -->
</div></div><div id="bricks-element-hxnhyk" class="bricks-element-hxnhyk bricks-element bricks-element-nav-menu"><nav class="bricks-nav-menu-wrapper mobile_landscape" role="navigation"><ul id="menu-footer" class="bricks-nav-menu mobile_landscape" role="menubar"><li id="menu-item-268517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-268517 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/advertise-with-us/">Advertise</a></li>
<li id="menu-item-271805" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-271805 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-271806" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271806 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review-policy/">Review Policy</a></li>
<li id="menu-item-271809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271809 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/editorial-policy/">Editorial Policy</a></li>
<li id="menu-item-297334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-297334 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/ethics-policy/">Ethics Policy</a></li>
</ul></nav>			<button class="bricks-mobile-menu-toggle mobile_landscape" role="button" aria-haspopup="true" aria-label="Mobile menu" aria-pressed="false">
				<span class="bar-top"></span>
				<span class="bar-center"></span>
				<span class="bar-bottom"></span>
			</button>
			<nav class="bricks-mobile-menu-wrapper left" role="navigation"><ul id="menu-footer-1" class="bricks-mobile-menu" role="menubar"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-268517 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/advertise-with-us/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-271805 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271806 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/review-policy/">Review Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271809 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/editorial-policy/">Editorial Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-297334 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/ethics-policy/">Ethics Policy</a></li>
</ul></nav><div class="bricks-mobile-menu-overlay"></div></div></div><div id="bricks-element-bqegfi" class="bricks-element-bqegfi bricks-container"><div id="bricks-element-vcqofi" class="bricks-element-vcqofi bricks-element bricks-element-text"><div class="text-wrapper"><p>MORE FROM <a href='https://www.cgmagonline.com/articles/features/cgm-monthly-top-10-reviews-november-2021/' title='CGM Monthly Top 10 Reviews: November 2021' >CGM</a></p>
<!-- AI CONTENT END 4 -->
</div></div><div id="bricks-element-ndjcfe" class="bricks-element-ndjcfe bricks-element bricks-element-nav-menu"><nav class="bricks-nav-menu-wrapper mobile_landscape" role="navigation"><ul id="menu-footer-2" class="bricks-nav-menu mobile_landscape" role="menubar"><li id="menu-item-271810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271810 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/job-application/">Jobs @ CGMagazine</a></li>
<li id="menu-item-271807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271807 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/about/">About</a></li>
<li id="menu-item-268521" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-268521 bricks-menu-item" role="menuitem"><a href="https://store.cgmagonline.com/">Subscribe</a></li>
<li id="menu-item-297335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-297335 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/contact-us/">Contact</a></li>
<li id="menu-item-271808" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271808 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/press/">Press</a></li>
</ul></nav>			<button class="bricks-mobile-menu-toggle mobile_landscape" role="button" aria-haspopup="true" aria-label="Mobile menu" aria-pressed="false">
				<span class="bar-top"></span>
				<span class="bar-center"></span>
				<span class="bar-bottom"></span>
			</button>
			<nav class="bricks-mobile-menu-wrapper left" role="navigation"><ul id="menu-footer-3" class="bricks-mobile-menu" role="menubar"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271810 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/job-application/">Jobs @ CGMagazine</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271807 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/about/">About</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-268521 bricks-menu-item" role="menuitem"><a href="https://store.cgmagonline.com/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-297335 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/contact-us/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271808 bricks-menu-item" role="menuitem"><a href="https://www.cgmagonline.com/press/">Press</a></li>
</ul></nav><div class="bricks-mobile-menu-overlay"></div></div></div></div></div><div id="bricks-element-rnuvjn" class="bricks-element-rnuvjn bricks-container"><div id="bricks-element-tongcv" class="bricks-element-tongcv bricks-element bricks-element-text"><div class="text-wrapper"><p>© 2021 <a href='https://www.cgmagonline.com/magazine-section/celebrate-torontos-birthday-cgm/' title='Celebrate Toronto\'s Birthday With CGM!' >CGMagazine</a> Publishing Inc. All Rights Reserved. <em>CGMagazine</em> May Earn A Portion Of <a href='https://www.cgmagonline.com/news/nintendo-dominates-holiday-sales-figures/' title='Nintendo Dominates Holiday Sales figures in Japan' >Sales</a> From Products That Are Purchased Through Our Site As Part Of Our Affiliate Partnerships With Retailers. The Material On This Site May Not Be Reproduced, Distributed, Transmitted, Cached Or Otherwise Used, Except With The Prior Written Permission Of CGMagazine. <a href="https://www.cgmagonline.com/?cmpscreen">Manage Cookie Settings</a></p>
<!-- AI CONTENT END 5 -->
</div></div><div id="bricks-element-quafuq" class="bricks-element-quafuq bricks-element bricks-element-code"><div id="nn_skinr"></div>
<div id="nn_skinl"></div></div></div></div></footer>
</div><!-- END #bricks-site-wrapper -->

		<div id="fb-root"></div>

		<div class="bricks-lightbox-wrapper">
			<div class="bricks-lightbox-inner"></div>
			<div class="close">×</div>
		</div>
		
    <script data-cfasync="false">
        var VUUKLE_CONFIG = {
            apiKey: "e3cc4954-915c-4fdd-9b1b-4aa901a993fd",
            articleId: "317137",
            title: 'SteelSeries Gears Up To Battle the Witch Queen With Limited Destiny 2 Peripherals',
            tags: "Bungie, Steelseries",
            author: "Chris De Hoog",
			        };
        (function () {
            var d = document,
                s = d.createElement('script');
            s.async = true;
            s.src = 'https://cdn.vuukle.com/platform.js';
            s.setAttribute('data-cfasync', 'false');
            (d.head || d.body).appendChild(s);
        })();
    </script>
<script id='eio-lazy-load-js-before' src="data:text/javascript;base64,dmFyIGVpb19sYXp5X3ZhcnM9eyJleGFjdGRuX2RvbWFpbiI6ImNkbi5jZ21hZ29ubGluZS5jb20iLCJza2lwX2F1dG9zY2FsZSI6MCwidGhyZXNob2xkIjowfQ==" defer></script>
<script src='https://www.cgmagonline.com/wp-content/plugins/ewww-image-optimizer/includes/lazysizes.min.js?ver=641.0' id='eio-lazy-load-js' defer data-deferred="1"></script>
<script src='https://www.cgmagonline.com/wp-content/plugins/league-table/public/assets/js/tablesorter/jquery.tablesorter-min.js?ver=2.13' id='dalt-tablesorter-js' defer data-deferred="1"></script>
<script src='https://www.cgmagonline.com/wp-content/plugins/league-table/public/assets/js/general-min.js?ver=2.13' id='dalt-general-js' defer data-deferred="1"></script>
<script id='bricks-scripts-js-extra' src="data:text/javascript;base64,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" defer></script>
<script src='https://www.cgmagonline.com/wp-content/themes/bricks/assets/js/bricks.min.js?ver=1643288767' id='bricks-scripts-js' defer data-deferred="1"></script>
<script src='https://www.cgmagonline.com/wp-content/plugins/perfmatters/js/lazyload.min.js?ver=1.8.6' id='perfmatters-lazy-load-js-js' defer data-deferred="1"></script>
<script src='https://www.cgmagonline.com/wp-content/plugins/wp-featherlight/js/wpFeatherlight.pkgd.min.js?ver=1.3.4' id='wp-featherlight-js' defer data-deferred="1"></script>
<script src='https://www.cgmagonline.com/wp-content/plugins/responsive-videos-fitvids/assets/js/jQuery.fitVids.js?ver=3.0.1' id='sgi-fitvids-js' defer data-deferred="1"></script>

		<script type="text/javascript" src="data:text/javascript;base64,alF1ZXJ5KGRvY3VtZW50KS5yZWFkeShmdW5jdGlvbigpe2pRdWVyeSgnLmVudHJ5LWNvbnRlbnQtYXNzZXQnKS5maXRWaWRzKCl9KQ==" defer></script>
		<script src="data:text/javascript;base64,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" defer></script><script type="text/javascript" id="perfmatters-delayed-scripts-js" src="data:text/javascript;base64,Y29uc3QgcGVyZm1hdHRlcnNEZWxheVRpbWVyPXNldFRpbWVvdXQocG1Mb2FkRGVsYXllZFNjcmlwdHMsNSoxMDAwKTtjb25zdCBwZXJmbWF0dGVyc1VzZXJJbnRlcmFjdGlvbnM9WyJrZXlkb3duIiwibW91c2Vtb3ZlIiwid2hlZWwiLCJ0b3VjaG1vdmUiLCJ0b3VjaHN0YXJ0IiwidG91Y2hlbmQiXTtwZXJmbWF0dGVyc1VzZXJJbnRlcmFjdGlvbnMuZm9yRWFjaChmdW5jdGlvbihldmVudCl7d2luZG93LmFkZEV2ZW50TGlzdGVuZXIoZXZlbnQscG1UcmlnZ2VyRGVsYXllZFNjcmlwdHMse3Bhc3NpdmU6ITB9KX0pO2Z1bmN0aW9uIHBtVHJpZ2dlckRlbGF5ZWRTY3JpcHRzKCl7cG1Mb2FkRGVsYXllZFNjcmlwdHMoKTtjbGVhclRpbWVvdXQocGVyZm1hdHRlcnNEZWxheVRpbWVyKTtwZXJmbWF0dGVyc1VzZXJJbnRlcmFjdGlvbnMuZm9yRWFjaChmdW5jdGlvbihldmVudCl7d2luZG93LnJlbW92ZUV2ZW50TGlzdGVuZXIoZXZlbnQscG1UcmlnZ2VyRGVsYXllZFNjcmlwdHMse3Bhc3NpdmU6ITB9KX0pfWZ1bmN0aW9uIHBtTG9hZERlbGF5ZWRTY3JpcHRzKCl7ZG9jdW1lbnQucXVlcnlTZWxlY3RvckFsbCgic2NyaXB0W2RhdGEtcG1kZWxheWVkc2NyaXB0XSIpLmZvckVhY2goZnVuY3Rpb24oZWxlbSl7ZWxlbS5zZXRBdHRyaWJ1dGUoInNyYyIsZWxlbS5nZXRBdHRyaWJ1dGUoImRhdGEtcG1kZWxheWVkc2NyaXB0IikpfSl9" defer></script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6e1afbc02ca381ac","version":"2021.12.0","r":1,"token":"ca71309f33974e77b7a443fb1b5a5ec6","si":100}' crossorigin="anonymous"></script>
</body>
</html>
<!-- Easy IO processing time: 0.13057684898376 seconds -->
<!-- Page generated by LiteSpeed Cache 4.4.7 on 2022-02-22 13:21:04 -->